• Welcome to the Chevereto user community!

    Here users from all over the world gather around to learn the latest about Chevereto and contribute with ideas to improve the software.

    Please keep in mind:

    • 😌 This community is user driven. Be polite with other users.
    • 👉 Is required to purchase a Chevereto license to participate in this community (doesn't apply to Pre-sales).
    • 💸 Purchase a Pro Subscription to get access to active software support and faster ticket response times.

Upload large images > 4.000 px

Adromia

Chevereto Member
Hello,

where can i change the option, i can upload larger pictures, more than 4.000 pixels?
 

Rodolfo

⭐ Chevereto Godlike
Chevereto Staff
Administrator
in config.php you can change the limit but that limit depens from your server config. For example, if you server allows only 2mb you can't override that limit.
 

Adromia

Chevereto Member
The picture is 2,3 MB big and has 5.120 x 3.840 Pixel @ 24 Bits pro Pixel.

If i upload the picture, i see after upload a white site and the picture was not uploaded / on my server.

This is my config file:

Code:
// Folders
/* If you change this, you also must change the folders name. */
define('DIR_UP','up/');
define('DIR_IM','images/'); // Change this to have something like /X/filename.jpg - where "X/" is the folder name. 
define('DIR_WORKING',DIR_UP.'working/');
define('DIR_TEMP',DIR_UP.'temp/');
define('DIR_TH','thumbs/');

// Min-Max values -> php.ini rules the nation...
$max_mb = '8'; // Max. image size (Mbytes)
$max_by = $max_mb*1048576; // (bytes)
$max_name = '20'; // Max. file name lenght.

// Thumbs
$mini_ancho = '150'; // Thumb width (pixels)
$mini_alto = '150'; // Thumb height (pixels)

// Resize
$lowres = '16'; // Min. resize value (pixels)
$higres = '10000'; // Max. resize value (pixels)

// Options
$lim_act = true; // true: Allows uploading just for your domain - false: Allows upload from anywhere (post from another website)
$debug_mode = false; // false: Debug OFF - true: Debug ON.
$cut_url = true; // true: Short URLs (TinyURL tr.im etc.) - false: normal url (http://mysite.com/images/image.jpg).
$cut_url_service = 'tinyurl'; // tinyurl
$cut_url_user = true; // If $cut_url = true -> true: Allows your users to cut their urls (preference) - false: Users can't choose to cut or not.
$allow_over_resize = false; // true: Allows over resize images - false: Don't allow over resize.
 

Rodolfo

⭐ Chevereto Godlike
Chevereto Staff
Administrator
It's a server issue. As any server it has limits on everything... Like upload size, execution time, etc.
 

Danny.Domb

👽 Chevereto Freak
you may check your server php configuration with :

(create a new php file)

add this in it

Code:
<?php phpinfo(); ?>

maybe the maximum height and wdith limit is in it =D (use ctrl+f and keywords =D)
 

Adromia

Chevereto Member
@Rodolfo I need ask my hoster.

@Danny.Domb This information is not listed. I use PHP 5.2.12
 

Adromia

Chevereto Member
I have found my problem. I have create a new file ".htaccess" with following content:

php_value memory_limit 128M

And it works now.
 
Top