• Welcome to the Chevereto User Community!

    Here, users from all over the world come together to learn, share, and collaborate on everything related to Chevereto. It's a place to exchange ideas, ask questions, and help improve the software.

    Please keep in mind:

    • This community is user-driven. Always be polite and respectful to others.
    • Support development by purchasing a Chevereto license, which also gives you priority support.
    • Go further by joining the Community Subscription for even faster response times and to help sustain this space

Problems with the rights.

Status
Not open for further replies.

ceo@optizone.ru

Chevereto Member
Website URL
http://imgdisk.ru

Chevereto version
3.9.0

Description of the issue
Good afternoon. After the server was moved, there was a problem with uploading images, as well as loggin/sign up. Error - Access is denied.
Now the site opens on the old server. Ip new server - 91.230.210.131

Screen of the site: http://joxi.ru/LmGn6VNcR4gKLr


Nginx logs:

Access: 185.25.62.46 - - [06 / July / 2017: 22: 10: 11 +0700] "POST / json HTTP / 1.1" 400 423 "http://imgdisk.ru/" "Mozilla / 5.0 (Windows NT 10.0 ); WOW64; rv: 53.0) Gecko / 20100101 Firefox / 5
3.0 "

Error: 2017/07/06 22:10:11 [error] 27410 # 0: * 162989 FastCGI sent to stderr: "PHP message: The request was denied" when reading the response header up, client: 185.25.62.46, server: imgdisk. Ru, request: «POST / json HTTP / 1.1», upstream: «fastcgi: // unix: /var/run/php-fpm-imgdisk.sock:», host: «imgdisk.ru», referrer: « Http: //imgdisk.ru/ »
 
When you move a website to another server there are always delays because of DNS propagation.

This is not Chevereto issue but DNS settings / propagation. Please refer to your hosting company.

Cheers,
Rodolfo.
 
Rodolfo, thanks for the answer, but I think the problem is different.

The final transfer of the site has not yet been implemented.
We check its operability on a new server by registering ip in "hosts". The site opens without problems, but when you try to upload an image or register: Access is denied.
 
Seems like you tested current server (IP 185.25.62.162). Steps to reproduce problem:
1) Add record in /etc/hosts (c:\windows\system32\drivers\etc\hosts on Windows) that imgdisk.ru at IP 91.230.210.131 (new server)
2) Open imgdisk.ru in "cold" browser session and try to upload image

I will try to collect debug info and post it here a bit later.

P.S.: you can check that new record in "hosts" working by running "ping imgdisk.ru" in console. It must refer to 91.230.210.131, not 185.25.62.162.
 
Status
Not open for further replies.

Chevereto Cloud

Back
Top