Error report

Status
Not open for further replies.

hyyat4host

Founder license
License owner
every time I got this error when I trying to upload images

Error report
  • 2019-08-02_17-32-59.png - SQLSTATE[HY000]: General error: 1364 Field 'image_delete_hash' doesn't have a default value
 

Rodolfo

Chevereto Developer
Chevereto Staff
I'm not seeing this affecting other installations. Please describe any db editing or previous thech support assistance.
 

hyyat4host

Founder license
License owner
dear I am not understand you

again

when I do that in my data base in phpmyadmin
ALTER TABLE `chv_images` DROP `image_delete_hash`;

the upload working for a while but the back the issue again

see attachment and try to upload
 

Attachments

Rodolfo

Chevereto Developer
Chevereto Staff
I don't understand you either. Where that drop came from? What are you doing?
 

hyyat4host

Founder license
License owner
ok go to web site and please test to insert
https://hyyathost.com/ and trying to upload picture from your side

as guest I can not upload at all see the atachment

but as user like you can rest with

user: ghassan
pass: 123123@123

you will see as the first attachment with aerror

General error: 1364 Field 'image_delete_hash' doesn't have a default value
 

Attachments

Rodolfo

Chevereto Developer
Chevereto Staff
Ok, This needs debug.

You have to describe exactly all what you did before getting this. Exactly everything, don't miss one single thing.

From that, I can analyze if this could be a bug or something else triggered at your end.
 

hyyat4host

Founder license
License owner
actually I did not any think
it is just suddenly that happened after last update
do you want to put for you the information for cpanel to take a look
 

Rodolfo

Chevereto Developer
Chevereto Staff
Chevereto doesn't use the chv_images.image_delete_hash column at all since v3.0.0 and when you update from 2.X to 3.X that column gets removed. It impossible that you install Chevereto 3 with that column present in the database.

That's why I asked to provide details. I know the system backwards and I know that there is something odd here. That column must not be there, simple as that.

I don't have any clue on why you have that colum there, the only thing I can suggest you is to try to stick to my database schema.
 

hyyat4host

Founder license
License owner
can i understand how to do that
stick to my database schema
and if i install a new one can i transfer all the images from old to new

and did that solve the problem
 
Status
Not open for further replies.
Top