• 🤗 This support section is delivered by the community, by other users of the software. Support in this section is not delivered by Chevereto Staff, remarks and issues in this section should be always taken with the appropriate context and care, with a grain of salt.

Chevereto not reading updated php.ini

robman510

Chevereto Member
I have deployed chevereto via portainer(docker), however it is not reading my updated php.ini settings and when I go to the Image Upload settings it still says my max upload size is 2M. In the docker-compose I have specified where the php.ini is located (see below). I originally had this problem before and solved it by the volume configuration below. Is there something else I need to update these settings? I have tried redeploying and rebooting the server. I'm not sure where its still pulling the default values from.

docker-compose:
volumes:
- /srv/rpimage/conf/Chevereto/chevereto_images:/var/www/html/images:rw
- /srv/rpimage/conf/php.ini:/etc/php/7.4/apache2/php.ini:ro

contents of php.ini:
upload_max_filesize = 50M
post_max_size = 50M
memory_limit = 512M
max_execution_time = 180
 

robman510

Chevereto Member
I figured it out a work around. My container was not loading the php.ini from my host system. So I used portainer's built in bash console for the chevereto container. Once inside I used "php --ini" to see where the file was located. I found the path for it but no php.ini was present or loaded. I changed to the directory shown and using "nano php.ini" I input the correct settings and saved. Then I rebooted the container from portainer. This has corrected my problem.
 
Top