Watermark no longer showing after 3.18 update

Pro

Core license
▶ Reproduction steps
  1. Update from 3.16.X (don't remember - can find if necessary) to 3.18.0
  2. Upload an image (user or admin level)
  3. Try the following in admin panel to troubleshoot
    1. Enable/disable watermarks
    2. upload new watermark
    3. Toggle "enable watermarks for X user level"
    4. Watermark settings for reference: https://www.dropbox.com/s/7y59w032oyrlylw/2021-04-14_18-17-09.png?dl=0
😢 Unexpected result

File uploads successfully but without watermark. Worked before the update just fine.
Graphics Library:ImageMagick 6.9.10-68 Q16 x86_64 2021-02-24 https://imagemagick.org

📃 Error log message
 

Pro

Core license
In case it's relevant, we use s3 external storage - but literally the only thing that has changed (besides toggling aforementioned settings) is the Chevereto version (by updating it)

Edit: I am not sure if this should go into bug tracking or Support but I'm sure you'll route it :)
 

Pro

Core license
I figured out what happened but am confused as to why.. The watermark percentage (size of it) used to be 2% and it was still that, but it made it so much smaller since the update that it just wasn't visible. I had to increase the size of the watermark to 15-20%+ to have it show at the same size as 2% used to be, and definitely it is not 1/5 the size of the image. So there seems to be an issue with the actual percentage value.
 

Pro

Core license
You can see these images from right after the update where the watermark is tiny in the corner (again this was with the same setting - 2% - that was working fine before): https://www.hostmyjunk.com/image/peGu3 & https://www.hostmyjunk.com/image/pLien (many other examples)

This is how it looked before the update with 2% set (the first two had the bug of a black background that I reported before): https://www.hostmyjunk.com/image/pL7LY & https://www.hostmyjunk.com/image/pLnco & https://www.hostmyjunk.com/image/pLMV8 - appropriate to the image size

Plenty of other examples https://www.hostmyjunk.com/explore/recent (the tiny watermarks indicate the time the script was updated)

Edit: From this point (this edit time) forward, we will be adjusting the size of the watermark to be smaller until the issue is fixed as some images are just overwhelmed by it. Letting you know in case you are referencing the site.
 

Pro

Core license
Hi,
Is there any kind of potential or estimated timeframe when this may be solved? Obviously you've got a lot of stuff on your list (really looking forward to v4!), just wanted to see if this will make it to the roadmap in the near future, as for the present moment, watermarks (i.e. our brand's main representation to the public) are all over the place, and making it not very appealing to upload images when sometimes literally the whole bottom of it is taken up with an image.
 

Rodolfo

Α & Ω
Chevereto Staff
Administrator
I've fixed this one by reverting to the old sizing method (area based) so you should get the same sizing as before the 3.18 update when using coqueto (3.20).
 

Pro

Core license
The quick resolution to this is greatly appreciated. Based on your post here it seems that will be later this month, but please let me know if that's wrong.

Thank you very much.
 
Top