upload issue after update to latest release

Status
Not open for further replies.

dale2015

Network license
License owner
Joined
Feb 22, 2015
Messages
28
Points
51
ive just upgraded to latest version of script 3.11.1 ever since updated image upload wont work 🎯Description of the issue


▶🚶‍Reproduction steps
😢Unexpected result

wont upload red exclamation mark on everything i try,and now keep getting 504 gateway error to

📃Error log message

4.png - SQLSTATE[42S22]: Column not found: 1054 Unknown column 'image_source_md5' in 'field list'
 
Last edited:

mmybaka

Network license
License owner
Joined
Oct 27, 2015
Messages
37
Points
58
1.Backup database
2.Modify this SQL statement
Code:
 ALTER TABLE `You mysql table prefix_images` ADD `image_source_md5` VARCHAR(32) CHARACTER SET utf8 COLLATE utf8_general_ci NULL DEFAULT NULL AFTER `image_source_md5`;
3.Execute SQL statement
 
Last edited:

dale2015

Network license
License owner
Joined
Feb 22, 2015
Messages
28
Points
51
Fatal error [400]: SQLSTATE[HY000] [1040] Too many connections
Triggered in /lib/G/classes/class.db.php at line 100

Stack trace:
#0 /lib/G/classes/class.db.php(111): G\DB->__construct()
#1 /app/loader.php(52): G\DB::getInstance()
#2 /index.php(20): include_once('/app/loader.php')

now im getting this pretty constant ,any advice please
 

JakeSully

Network license
Beta tester
Joined
Feb 23, 2014
Messages
270
Points
78
This error is something todo with your host and not script itself. As you can see mysql server is throwing to many connections and that it has reached it's maximum limit of how many connections can be done at once. So like @bee said if you use shared hosting. Contact them to have this solved or change web hosting company.
If you use vps, then you have to change max amount of connections to your mysql server in its configuration file and same if you use a dedicated server.

Also make new support topic for new issues, don't use same topic for new problems. Since it won't be as good because once main problem is fixed the topic will be marked as solved, so then people won't read it much after.
 
Reactions: Rodolfo

Rodolfo

Chevereto Developer
Chevereto Staff
Joined
Oct 7, 2008
Messages
16,531
Points
237
Location
Chevereto HQ
Website
rodolfoberrios.com
Seems that your server is not configured properly for the load of your website. In other words, your server is too small for the number of users trying to use your website.
 
Status
Not open for further replies.