upload issue after update to latest release

Version
3.11.1
Website URL
https://www.xxximagetpb.org
PHP version
5.6.38
Database driver
MariaDB
Database version
5.5.60
Web browser
chrome,firefox

dale2015

Network license
License owner
Joined
Feb 22, 2015
Messages
28
Likes
0
Points
51
#1
ive just upgraded to latest version of script 3.11.1 ever since updated image upload wont work 🎯Description of the issue


▶🚶‍Reproduction steps
😢Unexpected result

wont upload red exclamation mark on everything i try,and now keep getting 504 gateway error to

📃Error log message

4.png - SQLSTATE[42S22]: Column not found: 1054 Unknown column 'image_source_md5' in 'field list'
 
Last edited:

mmybaka

Network license
License owner
Joined
Oct 27, 2015
Messages
37
Likes
7
Points
58
#2
1.Backup database
2.Modify this SQL statement
Code:
 ALTER TABLE `You mysql table prefix_images` ADD `image_source_md5` VARCHAR(32) CHARACTER SET utf8 COLLATE utf8_general_ci NULL DEFAULT NULL AFTER `image_source_md5`;
3.Execute SQL statement
 
Last edited:

dale2015

Network license
License owner
Joined
Feb 22, 2015
Messages
28
Likes
0
Points
51
#3
Fatal error [400]: SQLSTATE[HY000] [1040] Too many connections
Triggered in /lib/G/classes/class.db.php at line 100

Stack trace:
#0 /lib/G/classes/class.db.php(111): G\DB->__construct()
#1 /app/loader.php(52): G\DB::getInstance()
#2 /index.php(20): include_once('/app/loader.php')

now im getting this pretty constant ,any advice please
 

bee

Well-Known Member
License owner
Joined
Dec 2, 2014
Messages
165
Likes
33
Points
78
Location
Thailand
Website
bee.creative.xxx
#4
  • bee

    bee

SQLSTATE[HY000] [1040] Too many connections
If you use shared hosting, change your hosting company.
If you use managed VPS, ask your host to resolve it.
If you use root servers, check your DB settings.
 

JakeSully

Network license
Beta tester
Joined
Feb 23, 2014
Messages
158
Likes
16
Points
68
#5
This error is something todo with your host and not script itself. As you can see mysql server is throwing to many connections and that it has reached it's maximum limit of how many connections can be done at once. So like @bee said if you use shared hosting. Contact them to have this solved or change web hosting company.
If you use vps, then you have to change max amount of connections to your mysql server in its configuration file and same if you use a dedicated server.

Also make new support topic for new issues, don't use same topic for new problems. Since it won't be as good because once main problem is fixed the topic will be marked as solved, so then people won't read it much after.
 

Rodolfo

Chevereto Guru-Guru
Staff member
Joined
Oct 7, 2008
Messages
15,993
Likes
4,187
Points
237
Location
Chevereto HQ
Website
rodolfoberrios.com
#6
Seems that your server is not configured properly for the load of your website. In other words, your server is too small for the number of users trying to use your website.