Implemented Upgrade to 3.13.X DB issues

Status
Not open for further replies.

Rodolfo

Chevereto Developer
Chevereto Staff
The 3.13.0 upgrade added ut8mb4 support in order to support emojis. We have been notified of DB upgrade issues because the system is not actually checking the actual DB version needed. The bug report: https://chevereto.com/community/threads/installation-issues-in-mysql-5-6.11248/

The minimum DB requirements are MySQL / MariaDB 10 and checking for these versions will start from v3.13.1 (revision).

If you are in the struggle of upgrading please complete the following procedure:

  1. Make sure that your DB server runs MySQL 8 / MariaDB 10.
  2. Process /update to get the 3.13.0 files (if you already did this you can skip this step)
  3. Go to /install?dump and copy all the queries
  4. Go to your SQL console (for example phpmyadmin) and run the queries in your Chevereto DB.
That should do it, please share your results.
 

javajiver

Network license
License owner
Just an FYI. We upgraded the free version on another installation/server a few days ago and had zero problems with it. Of course, it was running MariaDB 10.3 already.
 
Status
Not open for further replies.
Top