Confirmed PUP support for XenForo 2.1 isn't working on Mobile view

Version
3.15.2
PHP version
7.4.6
Database driver
MariaDB
Database version
10.3
Web browser
Chrome

rdn

Core license
License owner
▶🚶‍Reproduction steps
  1. Open a XenForo 2.1 page like thread view with PUP support via Mobile
  2. Button is present but isn't clickable
😢Unexpected result

Nothing happens when tap/click on the toolbar.
 

McAtze

Network license
Beta tester
I think the problem are the different toolbars for different devices/screens. If the sibling item is gone on smaller devices, also the chev button is gone.

Screenshot 2020-05-23 09.09.49.png
 
  • Like
Reactions: rdn

Rodolfo

Chevereto Developer
Chevereto Staff
The exact problem is that the editor changes the toolbar, like it literally re-parses all the bar when doing mobile so PUP losses its position and binding.

The only safe way is to put it outside the bar.
 

imagonos

Network license
License owner
Hello,

Is there a way to go back to the older version of PUP where you could place the button outside the box?
I got it figured out and it was definitely looking great but, now, since the update the button is no longer showing.

EDIT: For now I manually swapped the PUP for the 3.15.1 version. It seems to work.

Regards,
imagonos
 
Last edited:

imagonos

Network license
License owner
Hello,

if it's placed on top of the post reply and preview buttons it would also not ruin mobile responsive themes, that are deformed since the chevereto PUP button makes the width of the page too large. Just a suggestion. Or if there was a way for the PUP button to somehow hide the attach files button if we wanted to but I guess that has to be done on our end since pup is just a js file.

Regards,
imagonos.
 
Top