mod_rewrite install problem

Killer0561

New Member
Hi guys,

I have problems with the installation of chevereto. I've already enabled mod_rewrite in my apache2 configuration, but I still can not find "install".


Not Found
The requested URL /install was not found on this server.




greeting

Killer0561
 

Killer0561

New Member
make sure that the .htaccess file is in root path where index.php, is located.
the htaccess exits in the root folder, I can confirm that.

Loaded doesn't means working. Check AllowOverride.
<VirtualHost *:80>
ServerAdmin admin@xxx.de
ServerName imagehosting.xxx.de
DocumentRoot /var/www/_[xxx]_Seiten/imagehosting
<Directory /var/www>
Options Indexes FollowSymLinks MultiViews
AllowOverride All
Order allow,deny
Allow from all
</Directory>
ErrorLog /var/log/apache2/error/-(_09_)-imagehosting-error.log
CustomLog /var/log/apache2/access/-(_09_)-imagehosting-access.log combined
ServerSignature Off
</VirtualHost>

Is it correct that way? Or did I do something wrong? Because it is currently configured with me.


greeting

Killer0561
 

Killer0561

New Member
mod_rewrite works with e107 content management system without problems.
only chevereto makes problems for me, i dont know why.

greeting

Killer0561
 

Rodolfo

Chevereto Developer
Chevereto Staff
Again, URL rewriting is issued by your server which only "proxy" the request to Chevereto index.php file.

If your server is not doing that then the problem is your server which is not mapping /path/request to Chevereto front.

This forum is for Chevereto support, not for your server.
 

JakeSully

Network license
Beta tester
that rewrite file is wrong, it should be following content inside.

your .htaccess should not be
Code:
<VirtualHost *:80>
ServerAdmin admin@xxx.de
ServerName imagehosting.xxx.de
DocumentRoot /var/www/_[xxx]_Seiten/imagehosting
<Directory /var/www>
Options Indexes FollowSymLinks MultiViews
AllowOverride All
Order allow,deny
Allow from all
</Directory>
ErrorLog /var/log/apache2/error/-(_09_)-imagehosting-error.log
CustomLog /var/log/apache2/access/-(_09_)-imagehosting-access.log combined
ServerSignature Off
</VirtualHost>
It should have following code
Code:
# Disable server signature
ServerSignature Off



# Disable directory listing (-indexes), Multiviews (-MultiViews) and enable Follow system links (+FollowSymLinks)
Options -Indexes
Options -MultiViews
Options +FollowSymLinks

<IfModule mod_rewrite.c>

    RewriteEngine On

    # If you have problems with the rewrite rules remove the "#" from the following RewriteBase line
    # You will also have to change the path to reflect the path to your Chevereto installation
    # If you are using alias is most likely that you will need this.
    #RewriteBase /

    # 404 images
    # If you want to have your own fancy "image not found" image remove the "#" from RewriteCond and RewriteRule lines
    # Make sure to apply the correct paths to reflect your current installation
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule images/.+\.(gif|jpe?g|png|bmp) - [NC,L,R=404]
    #RewriteRule images/.+\.(gif|jpe?g|png|bmp) content/images/system/default/404.gif [NC,L]

    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_URI} !\.(css|js|html|htm|rtf|rtx|svg|svgz|txt|xsd|xsl|xml|asf|asx|wax|wmv|wmx|avi|bmp|class|divx|doc|docx|exe|gif|gz|gzip|ico|jpe?g|jpe|mdb|mid|midi|mov|qt|mp3|m4a|mp4|m4v|mpeg|mpg|mpe|mpp|odb|odc|odf|odg|odp|ods|odt|ogg|pdf|png|pot|pps|ppt|pptx|ra|ram|swf|tar|tif|tiff|wav|wma|wri|xla|xls|xlsx|xlt|xlw|zip)$ [NC]
    RewriteRule . index.php [L]

</IfModule>
So add whole code from 2nd box into .htaccess after the content from first box. Make a space between so there is old coding then space then new coding, save it and that should hopefully make rewrite urls work just fine.

or copy all of the code from bellow
Code:
<VirtualHost *:80>
ServerAdmin admin@xxx.de
ServerName imagehosting.xxx.de
DocumentRoot /var/www/_[xxx]_Seiten/imagehosting
<Directory /var/www>
Options Indexes FollowSymLinks MultiViews
AllowOverride All
Order allow,deny
Allow from all
</Directory>
ErrorLog /var/log/apache2/error/-(_09_)-imagehosting-error.log
CustomLog /var/log/apache2/access/-(_09_)-imagehosting-access.log combined
ServerSignature Off
</VirtualHost>

# Disable server signature
ServerSignature Off



# Disable directory listing (-indexes), Multiviews (-MultiViews) and enable Follow system links (+FollowSymLinks)
Options -Indexes
Options -MultiViews
Options +FollowSymLinks

<IfModule mod_rewrite.c>

    RewriteEngine On

    # If you have problems with the rewrite rules remove the "#" from the following RewriteBase line
    # You will also have to change the path to reflect the path to your Chevereto installation
    # If you are using alias is most likely that you will need this.
    #RewriteBase /

    # 404 images
    # If you want to have your own fancy "image not found" image remove the "#" from RewriteCond and RewriteRule lines
    # Make sure to apply the correct paths to reflect your current installation
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule images/.+\.(gif|jpe?g|png|bmp) - [NC,L,R=404]
    #RewriteRule images/.+\.(gif|jpe?g|png|bmp) content/images/system/default/404.gif [NC,L]

    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_URI} !\.(css|js|html|htm|rtf|rtx|svg|svgz|txt|xsd|xsl|xml|asf|asx|wax|wmv|wmx|avi|bmp|class|divx|doc|docx|exe|gif|gz|gzip|ico|jpe?g|jpe|mdb|mid|midi|mov|qt|mp3|m4a|mp4|m4v|mpeg|mpg|mpe|mpp|odb|odc|odf|odg|odp|ods|odt|ogg|pdf|png|pot|pps|ppt|pptx|ra|ram|swf|tar|tif|tiff|wav|wma|wri|xla|xls|xlsx|xlt|xlw|zip)$ [NC]
    RewriteRule . index.php [L]

</IfModule>
So this is why your rewrite url is not working, since it's missing correct .htaccess coding.
 
Top