Hotfix [3.18.1+] WEBP image support is not enabled

Status
Not open for further replies.

Rodolfo

Don Chevere
Chevereto Staff
Administrator
License owner
It has come to attention that 3.18.1 broke some websites due to the lack of webp support.

Regarding this please acknowledge:
  1. WEBP support was introduced in 3.14.0 and WEBP wasn't being checked until 3.18.1
  2. All image formats (except webp) have been always required, regardless if enabled/disabled in dashboard
  3. WEBP will keep being a requirement
  4. Imagick should be preferred
If you installed 3.18.1 and you can't enable webp then open app/lib/integrity-check.php and change this:

app/lib/integrity-check.php:
$mustHaveFormats = ['PNG', 'GIF', 'JPG', 'BMP', 'WEBP'];
To this:
app/lib/integrity-check.php:
$mustHaveFormats = ['PNG', 'GIF', 'JPG', 'BMP'];

🤗 Hope you can get webp support rather than edit this on every single update.
 
Status
Not open for further replies.
Top